Can't assign IP Domain to Data Collector
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Can't assign IP Domain to Data Collector

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Article ID: 196718

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Updated On: 02-13-2024

Products

CA Performance Management Network Observability

Issue/Introduction

Installed new Data Collector (DC) in our DX NetOps Performance Management (PM) environment.

After successful installation attempting to assign new DC to IPDomain. It spins and spins and then gives error. 

Data Collector could not be assigned to the IP Domain. 

The data collector was successfully sent a re-assignment message but we could not confirm re-assignment. Please check the appropriate log files.
 
IP Domain re-assignment fails. When examining the (default path) /opt/IMDataCollector/apache-karaf-<version>/etc/com.ca.im.dm.core.collector.cfg file these variables for the Tenant and IP Domain values may or may not be set.
  • collector-manager-tenant-id
  • collector-manager-ip-domain-id

This has been seen when the values are correct, and when they did not get set or updated to new values.

This has been seen for existing Data Collectors that have been emptied of items as well as new Data Collectors being added to an existing environment.

This message may be seen in the  (default path) /opt/IMDataCollector/apache-karaf-<version>/data/log/dc_registration.log file.

WARN  | andler-thread-11 | 2022-12-14T16:33:55,314 | DataCollectorRegistration | ller.impl.DCMRegistrationManager  245 | onRegistration: | Tenant iRep is NULL for DC Registration ( Host: <DC_HostName>, IP Domain:  )

Environment

All supported DX NetOps Performance Management Data Collector releases

Cause

Undetermined due to inability to reproduce.

Resolution

The following solutions are dependent on whether or not the values in the (default path) /opt/IMDataCollector/apache-karaf-<version>/etc/com.ca.im.dm.core.collector.cfg file for Tenant and Domain are set.

  1. Both Tenant and Domain variables in the com.ca.im.dm.core.collector.cfg file are set.
    1. In this case the solution is normally to simple restart the DC services.
      1. Stop the dcmd and activemq services
        • RH 6.x:
          1. system dcmd stop
          2. system activemq stop
        • RH 7.x:
          1. systemctl stop dcmd
          2. systemctl stop activemq
      2. Start the dcmd and activemq services
        • RH 6.x:
          1. system dcmd start
          2. system activemq start
        • RH 7.x:
          1. systemctl start dcmd
          2. systemctl start activemq
      3. After the restart check the Data Collector Status page under Administration->Monitored Items Management. After a few minutes refresh the page if needed and the Tenant and IP Domain should now be set and editable.
    2. Restart of the services didn't fix the problem despite the values being set in the com.ca.im.dm.core.collector.cfg file?
      1. Stop the DC dcmd and activemq services (same commands as above).
      2. Remove the (default path) /opt/IMDataCollector/apache-karaf/data directory.
        • Delete it or rename the directory to data.<date> if deletion is not an option or log file preservation is required.
      3. Remove the (default path) /opt/IMDataCollector/apache-karaf/deploy/local-jms-broker.xml file. Delete it the file so it's no longer in the directory.
      4. Start the DC services.
      5. NOTE: This iteration of the problem, where the com.ca.im.dm.core.collector.cfg is updated but isn't used post restart, is a known issue fixed in 22.2.4 and newer releases.
        • Caused by the DC cache not updating with the configuration changes post restart.
        • Once the condition is present only forcing a rebuild of the cache using these steps resolves it.
  2. Both, or one, of the Tenant and Domain variables in the com.ca.im.dm.core.collector.cfg file are not set, or are set incorrectly.
    1. Stop the dcmd and activemq services
      • RH 6.x:
        1. system dcmd stop
        2. system activemq stop
      • RH 7.x:
        1. systemctl stop dcmd
        2. systemctl stop activemq
    2. Edit the com.ca.im.dm.core.collector.cfg file, setting the variables correctly.
      1. This is how they would look if setting them to the Default Tenant and Default IP Domain, which is the correct value to put.
        1. collector-manager-tenant-id=Default Tenant
        2. collector-manager-ip-domain-id=Default Domain
      2. Save the changes after editing the variable values.
    3. Start the dcmd and activemq services
      • RH 6.x:
        1. system dcmd start
        2. system activemq start
      • RH 7.x:
        1. systemctl start dcmd
        2. systemctl start activemq
    4. After the restart check the Data Collector Status page under Administration->Monitored Items Management. After a few minutes refresh the page if needed and the Tenant and IP Domain should not be set and editable.

Additional Information

If the above solutions do not resolve the problem please open a new Support Case for further investigation. When doing so be sure to attach a fresh diagnostics logging package from the problem DC, via the re.sh script, to the new case.

Instructions for running the re.sh script are found on the Unable to Resolve Issue documentation page.