DataPower org/jaxen/JaxenException

book

Article ID: 196554

calendar_today

Updated On:

Products

CA Application Performance Management SaaS

Issue/Introduction

When trying to monitor DataPower by using SaaS Infrastructure Agent, below error message is appearing under the Agent logs and avoid DataPower start:

[ERROR] [IntroscopeAgent.DataPowerMonitor] DataPower Metric Poller failed
java.lang.NoClassDefFoundError: org/jaxen/JaxenException
 at org.dom4j.DocumentFactory.createXPath(DocumentFactory.java:222)
 at org.dom4j.DocumentHelper.createXPath(DocumentHelper.java:121)
 at com.ca.apm.extensions.dp.rt.ResponseBuilderImpl.createXPath(ResponseBuilderImpl.java:59)
 at com.ca.apm.extensions.dp.rt.ResponseBuilderImpl.build(ResponseBuilderImpl.java:39)
 at com.ca.apm.extensions.dp.DataPowerMetricPoller.getDeviceInfo(DataPowerMetricPoller.java:171)
 at com.ca.apm.extensions.dp.DataPowerMetricPoller.run(DataPowerMetricPoller.java:98)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
 at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
 at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
 at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
 at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.ClassNotFoundException: org.jaxen.JaxenException
 at com.wily.util.extension.JarExtension$AllPermissionsClassLoader.findClass(JarExtension.java:326)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:419)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:352)
 ... 13 more


Cause

This is happening due to a miss startup class into Agent side, it often happens when you are trying to monitor an unsupported DataPower release.

Environment

DataPower 7.x
Application Performance Management SaaS Agent.

Resolution

This is happening due to a miss startup class into Agent side, it often happens when you are trying to monitor an unsupported DataPower release.

There is a certification request in progress in order to support DataPower7x, for further information about this request, please raise a ticket and ask information about the below certification:

DE472431

Additional Information

Compatibility guide:

https://techdocs.broadcom.com/us/product-content/status/compatibility-matrix/application-performance-management-compatibility-guide.html?r=2