CA API Gateway 10 (software Install) Unable to connect to service via SSL (HTTPS)

book

Article ID: 196548

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

If you are using Gateway version 10 in a Software deployed form factor with AdoptOpenJDK 1.8.0_252 or higher you may see this error message when trying to hit endpoints over SSL/HTTPS

  WARNING   3016 Request routing failed with status -1 (Undefined)
 

Cause

AdoptOpenJDK 1.8.0_252+ is incompatible with Gateway version 10.0 in the software form factor.

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-api-management/api-gateway/10-0/release-notes/known-issues.html#concept.dita_3288dfc184e6cf131e7db6b436b1af0bbd822000_jdk252_gw10

 

Environment

Release : 10.0

Component : API GATEWAY

Resolution

 
Software Gateway users looking to install AdoptOpenJDK 1.8.0_252+ should upgrade their Gateway to version 10.0 CR1 or higher

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-api-management/api-gateway/10-0/release-notes/resolved-issues.html#concept.dita_bd083e022acc2d23c48d7b72fdad6bdad15da412_ResolvedinVersion10cr1

Additional Information

Where to get Gateway 10 CR1 (or higher if available)

https://support.broadcom.com/external/content/release-announcements/CA-API-Gateway-Solutions--Patches/3024

https://ftp.broadcom.com/user/downloads/pub/API_Management/Gateway/CR/Layer7_API_Gateway_v10.0.00-CR01.zip

(Please note that this link is for v10 CR01.  If there is a newer CR patch please use that instead since these are cumulative patches in which the latest patch includes all previous fixes)

How to install a patch on the Gateway software form factor:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-api-management/api-gateway/10-0/install-configure-upgrade/upgrade-the-gateway/understand-gateway-patches/patch-a-software-gateway.html#concept.dita_7a65fe3cd2ae33792fedbff41e3e35fb684a9360_InstallaPatch