Restart pending status on two servers even though a reboot had happened
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Article ID: 196442
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Updated On:
Products
Patch Management Solution
Issue/Introduction
The Software Update tab shows a restart pending status on two DNS servers even though a reboot had happened and both Windows and the STPatchAssessment.xml showed the updates as having been installed.
Environment
Patch Management 8.5 RU3 and later
Cause
The registry key, HKLM\SOFTWARE\Altiris\Altiris Agent\Patch Management\RebootRequired, was still set to 1 even after a reboot had been done. This may have been a fluke or maybe the registry is secured and didn't allow the Symantec Management Agent (SMA) to update this registry key.
Resolution
Do the following:
Manually change the HKLM\SOFTWARE\Altiris\Altiris Agent\Patch Management\RebootRequired registry key from 1 to 0
Restart the SMA agent service.
Run another assessment scan The updates should change to a status of installed. The compliance reports also should update and show these updates as now being installed.