Asset Information subview attributes not updated in Spectrum SRM for VMware ESX containers

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Article ID: 196435

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

Changes to the Asset Information subview attributes in OneClick do not get updated in SRM.

This happens only with VMware ESX container models.

 

Cause

SRM depends on contact_Status attribute value of models in SRM as it will not update devices which are not reachable. However these are container models and cannot be polled or pinged so will never get updated, as they appear unreachable based on this attribute.

Environment

Spectrum Release : All as of August, 2020.

 

Resolution

As a workaround, update ESX container models attribute Dev_contact_status i.e 0x110ed to "1" and the customer asset attributes will get updated.

This will be fixed in the upcoming release via code changes to allow polling these container models irrespective of dev_contact_status value in SRM .