Persistent system error, Error writing data to client-side row cache. Verify that the directory specified by the java.io.tmpdir property in logs

book

Article ID: 196380

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

On the Clarity environment we have a persistent system error on multiple pages.

In app logs we can see the error:

Caused by: java.sql.SQLException: [CA Clarity][Oracle JDBC Driver]Error writing data to client-side row cache. Verify that the directory specified by the java.io.tmpdir property exists and the current user has permission to read from and write to that directory.

Cause

  • Clarity uses OS temp directory by default, so the user running the services must have correct permissions to C:\TEMP or /var/tmp or /tmp
  • Optionally -Djava.io.tmpdir can be set in properties.xml. If this is not correctly set, you will have this exact error message

 

Environment

Release : All Supported Clarity releases

Component : CA PPM SAAS INSTALLATION AND UPGRADE

Resolution

This error indicates that the Java Temp directory has to be correctly set up.

1. Please check the properties.xml in JVM parameters and ensure that the directory set up as java.io.tmpdir exists and the Clarity user has permissions to access and write to it.

2. Once corrected, restart the services 

This should resolve the issue

 

Additional Information

Note: If Djava.io.tmpdir is used, we recommend setting it on both APP and BG, and redeploying all services