Clarity System error writing data to client-side row cache on tmpdir
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Clarity System error writing data to client-side row cache on tmpdir

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Article ID: 196380

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

On the Clarity environment there is a persistent system error on multiple pages. In app logs there is an error:

Caused by: java.sql.SQLException: [CA Clarity][Oracle JDBC Driver]Error writing data to client-side row cache. Verify that the directory specified by the java.io.tmpdir property exists and the current user has permission to read from and write to that directory.

Environment

Release : All Supported Clarity releases

Cause

  • Clarity uses OS temp directory by default, so the user running the services must have correct permissions to C:\TEMP or /var/tmp or /tmp
  • Optionally -Djava.io.tmpdir can be set in properties.xml. If this is not correctly set, you will have this exact error message

Resolution

  • This error indicates that the Java Temp directory has to be correctly set up.
  • Check the properties.xml in JVM parameters and ensure that the directory set up as java.io.tmpdir exists and the Clarity user has permissions to access and write to it.
  • For more information on how to do it check Setting -Djava.io.tmpdir on Clarity Java JVM parameters
  • Once corrected, restart the services 

Additional Information

Note: If Djava.io.tmpdir is used, we recommend setting it on both APP and BG, and redeploying all services