Rally: Adding Test Case to Test Set results in "Could not add artifact to collection" Error
search cancel

Rally: Adding Test Case to Test Set results in "Could not add artifact to collection" Error

book

Article ID: 196376

calendar_today

Updated On:

Products

Rally SaaS Rally On-Premise

Issue/Introduction

When trying to add another Test Case to a Test Set with existing Test Cases, the following error is seen:

Could not add artifact to collection

 

Environment

Release : SAAS

Component : AGILE CENTRAL

Cause

This can be caused when one of the Test Cases associated with the Test Set has been deleted, however it still shows on the list.

Resolution

To resolve this, the offending Test Case must be identified and undeleted from the Recycle Bin.

To do this,

  1. Open the Test Set's Test case list in one browser window
  2. Open a second browser window and open the Recycle Bin
  3. Click the Filter button to show filters
  4. Change "Filter by Type" to Test Cases
  5. Compare the two lists and look for a Test Case on the Test Set list that also exists in the Recycle Bin
  6. Once found, click the gear icon next to the Test Case and choose Restore
  7. You can now add the Test Case you were originally attempting to add

 

After this, you should be able to delete the originally deleted Test Case again as this should be an isolated incident and this is generally not a reproducible issue.