Spectrum Installation is taking a very long time (2+ hours) , log message: cygperl5_26.dll: Loaded to different address
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Spectrum Installation is taking a very long time (2+ hours) , log message: cygperl5_26.dll: Loaded to different address

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Article ID: 196355

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Updated On:

Products

Spectrum

Issue/Introduction

Spectrum Installation is taking a very long time (2 plus hours). Any idea what may cause this? 

Environment

Release : 10.x

Component : SPECTRUM CORE

Cause

Checking the Installation logs and there is a rolling message: 

3 [main] perl 11892 child_info_fork::abort: F:\win32app\Spectrum\NT-Tools\SRE\bin\cygperl5_26.dll: Loaded to different address: parent(0xE80000) != child(0xE10000)

Resolution

Searching online on "cygperl5_26.dll: Loaded to different address" and several forums on the error can be found. 

The most common reason is having Anti-Virus running at the time of install. 

Recommend to verify Anti-Virus is DISABLED and re-do the installation. 

Issue may also be conflict in Cygwin library files within the OS. try /usr/bin/rebaseall -v or cd /usr/bin && ./rebaseall -v

Additional Information

Here are some links for reference: 

https://stackoverflow.com/questions/37602608/cygwin-error-child-info-forkabort-loaded-to-different-address

https://stackoverflow.com/questions/9300722/cygwin-error-bash-fork-retry-resource-temporarily-unavailable

https://support.microsoft.com/en-us/help/4561616/windows-10-update-kb4561616

Spectrum documentation refereincing the application should be excluded from all AV scanning:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/dx-netops/23-3/Fault-Monitoring-with-DX-Spectrum/installing-and-upgrading/fresh-install/system-requirements-for-installing-ca-spectrum.html#concept.dita_0959071f44b2392b0d373bc2348eacdb481cf0ae_SystemSupportandSetupConsiderations

Antivirus Software and Data Backup
DX NetOps Spectrum does not include the antivirus software. We recommend installing your preferred antivirus software to protect your networking environment.  To avoid database corruption, exclude DX NetOps Spectrum  installation areas and DX NetOps Spectrum  files from scans by any local or remote instances of the antivirus software. 
 
DX NetOps Spectrum installation areas include OneClick and Report Manager installation areas.  Exclude all DX NetOps Spectrum
 installation areas, including OneClick and Report Manager installation areas, from scans by data backup programs.

To avoid database corruption, exclude installation areas and files from scans by any local or remote instances of antivirus software. Installation areas include OneClick and Report Manager installation areas.