No users found in LDAP server

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Article ID: 196343

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Clarity PPM On Premise

Issue/Introduction

Running the job LDAP - Synchronize New and Changed Users after setting up a new integration with LDAP.

The job is not synchronizing any new users.

Enabling debug messages on the security component com.niku.security category showed the following log messages:

<DEBUG date="" user="clarity:admin" session="" action="LDAP - Synchroniser les utilisateurs nouveaux et modifiés" thread="Dispatch LDAP - Synchroniser les utilisateurs nouveaux et modifiés : [email protected] (tenant=clarity)" category="com.niku.security.directory.LDAPAddModifySyncAgent">
<![CDATA[Begin the add/modify-users sync process...]]></DEBUG>
<DEBUG date="2020-07-24 13:01:19,117" user="clarity:admin" session=" action="LDAP - Synchroniser les utilisateurs nouveaux et modifiés" thread="Dispatch LDAP - Synchroniser les utilisateurs nouveaux et modifiés : [email protected] (tenant=clarity)" category="com.niku.security.directory.LDAPDirectoryService">
<![CDATA[Directory Server URL: ldaps://ldapserver:636]]></DEBUG>
<DEBUG date="2020-07-24 13:01:19,127" user="clarity:admin" session="" action="LDAP - Synchroniser les utilisateurs nouveaux et modifiés" thread="Dispatch LDAP - Synchroniser les utilisateurs nouveaux et modifiés : [email protected](tenant=clarity)" category="com.niku.security.directory.LDAPDirectoryService">
<![CDATA[No ds entry found..]]></DEBUG>
<DEBUG date="2020-07-24 13:01:19,128" user="clarity:admin" session="" action="LDAP - Synchroniser les utilisateurs nouveaux et modifiés" thread="Dispatch LDAP - Synchroniser les utilisateurs nouveaux et modifiés : [email protected](tenant=clarity)" category="com.niku.security.directory.LDAPDirectoryService">
<![CDATA[Provider URL used for searching:ldaps://ldapserver:port/OU=,DC=,]]></DEBUG>
<DEBUG date="2020-07-24 13:01:19,531" user="clarity:admin" session="" action="LDAP - Synchroniser les utilisateurs nouveaux et modifiés" thread="Dispatch LDAP - Synchroniser les utilisateurs nouveaux et modifiés : [email protected](tenant=clarity)" category="com.niku.security.directory.LDAPDirectoryService">
<![CDATA[Search filter used to get users (using pagination):(&(objectClass=Person)(modifyTimeStamp<=20200724110119))]]></DEBUG>
<DEBUG date="2020-07-24 13:01:19,538" user="clarity:admin" session="" action="LDAP - Synchroniser les utilisateurs nouveaux et modifiés" thread="Dispatch LDAP - Synchroniser les utilisateurs nouveaux et modifiés : [email protected](tenant=clarity)" category="com.niku.security.directory.LDAPDirectoryService">
<![CDATA[Total users: 0]]></DEBUG>
<INFO date="2020-07-24 13:01:19,540" user="clarity:admin" session="" action="LDAP - Synchroniser les utilisateurs nouveaux et modifiés" thread="Dispatch LDAP - Synchroniser les utilisateurs nouveaux et modifiés : [email protected] (tenant=clarity)" category="com.niku.security.directory.LDAPDirectoryService">
<![CDATA[No users found in directory server to synchronize with CA PPM]]></INFO>
<DEBUG date="2020-07-24 13:01:19,540" user="clarity:admin" session="" action="LDAP - Synchroniser les utilisateurs nouveaux et modifiés" thread="Dispatch LDAP - Synchroniser les utilisateurs nouveaux et modifiés : [email protected](tenant=clarity)" category="com.niku.security.directory.LDAPAddModifySyncAgent">
<![CDATA[End of add/modify-users sync process...]]></DEBUG>

Cause

The Date/Time Format was not properly set for the LDAP server.

Environment

Release : 15.8.1

Component : CA PPM APPLICATION

Resolution

Reconfigure the Date/Time Format, in the LDAP section on the CSA in Clarity PPM.
Change the value from yyyyMMddHHmmss to yyyyMMddHHmmss.0Z

Further information on how to setup the Integration with LDAP and troubleshoot it can be found in the guide:
Define the LDAP Server Properties