Acquire failed for PTF using CA CSM. Please check the spelling of the PTF.

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Article ID: 196279

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Updated On:

Products

CA Mainframe Software Manager (Chorus Software Manager) CA Chorus Software Manager

Issue/Introduction

Attempted to order new PTF SO12874 through CA Chorus Software Manager (CSM) using the Add External Maintenance method, but it failed.

The message shown in the task output reads..."Please check the spelling of the PTF: SO12874"...but this is not accurate.

 

 

 

 

Cause

Found "status code 401" error in the MSMTC output

The HTTP 401 Unauthorized client error status response code indicates that the request has not been applied because it lacks valid authentication credentials for the target resource. This status is sent with a WWW-Authenticate header that contains information on how to authorize correctly.

 INFO  (Task Thread 6012 - Acquire Published Solution SO12874) 2020-07-30 13:07:06,536 (GetSingleSolution.java:64): Processing PTF SO1
2874 using Site 123456
DEBUG (Task Thread 6012 - Acquire Published Solution SO12874) 2020-07-30 13:07:06,617 (GetSingleSolution.java:68): Web Service #10c -
  Product Single Solutions took 0 seconds (url: https://supportservices.ca.com/support/apars/SO14022/os/OS/dtls?site=123456&dwnldtp=ftp)
INFO  (Task Thread 6012 - Acquire Published Solution SO12874) 2020-07-30 13:07:06,621 (GetSingleSolution.java:77): Unable to fetch So
lution information for PTF SO12874, status code: 401
 
Most likely error is in relation to the userid/password combination needed to access the CA Portal (CA Support Online Account).

Environment

Release : 6.0
Component : MSM PRODUCT ACQUISITION SERVICE

Resolution

 Go into Settings and update the login information for the affected user. Be sure to click on the apply button at the bottom of the page to save changes.

 

Attachments