Resource Unavailable errors in SPE
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Resource Unavailable errors in SPE

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Article ID: 196218

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

While reviewing your Symantec Protection Engine (SPE) logs, you note the following error:

Resource Unavailable

Environment

SPE 9.x

Cause

"Resource Unavailable" errors are a primary indicator that the memory, and InMemoryFile settings, need to be increased.

Resolution

Increase the physical memory on each SPE and set the InMemoryFilesystemSize and InMemoryFileScanCacheSize settings to 40% of the installed RAM on the scanner.  Note that these two settings should always be the same number, additionally the maximum value for these settings is 128GB.

Confirm physical memory in MB on each SPE by doing one of the following:

  • At the Windows cmd prompt, type:
    systeminfo | find "Physical Memory"
  • At the Linux bash prompt, type:
    free -h

To set the InMemory file settings using the SPE 9.x console:

  1. Open the SPE 9 console and click "Change"
  2. Select the server or server group to check or change
  3. Click "Select"
  4. Identify the current values for "Maximum In-Memory File System Size (in MB)" and "Maximum In-Memory Scan Cache Size (in MB)"
  5. Set these two values to 40% of the physical memory
  6. At the top of the SPE 9 console, click "Apply changes"
  7. On the Apply Changes dialog box, click "Apply changes"
  8. On the Operation Status dialog box, click "Close"

To set the InMemory file settings using the XMLModifer:

  1. Open your terminal or command prompt with administrative privileges.
  2. Change directory to <install dir>/bin on Linux or <install dir> on Windows.
  3. Use the following xmlmodifier commands, using 40% of the physical memory as <value>:
  • Windows:
    .\xmlmodifier.exe -s //filtering/Container/InMemoryFilesys​temSize/@value <value> filtering.xml

.\xmlmodifier.exe -s //filtering/Container/InMemoryFileScanCacheSize/@value <value> filtering.xml

  • Linux:

./xmlmodifier -s //filtering/Container/InMemoryFilesys​temSize/@value <value> filtering.xml

./xmlmodifier -s //filtering/Container/InMemoryFileScanCacheSize/@value <value> filtering.xml

   4. Restart the Symantec Protection Engine service to release or reallocate memory correctly:

  • Windows:

Net Stop symcscan

Net Start symcscan

  • Linux:

/etc/init.d/symcscan restart