Machines are not showing under the the Software Update plugin Installation policy
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Machines are not showing under the the Software Update plugin Installation policy

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Article ID: 196186

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Updated On:

Products

Client Management Suite IT Management Suite Patch Management Solution

Issue/Introduction

Most commonly seen issues:

  1. Machines are not being targeted to install the Software Update plugin (Patch Management)
  2. Machines are showing "Plugin not started" message on the Altiris UI
  3. Machines not being able to run the "Windows Assessment Scan" due to their names not being shown under the specific target.

Environment

ITMS 8.x

Cause

Machines are part of scopes other than the default ones:

  1. Patch Management Rollout
  2. Patch Management Administrators

Resolution

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WARNING: Prior to making the following changes, verify that you have a current and valid backup of your database!

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There are two workarounds:

  1. Move the needed machines to one of the following scopes:
    1. Patch Management Rollout
    2. Patch Management Administrators
  2. Add the Symantec Administrator scope to the following targets:
    1. All Computers requiring Software Update Plug-in Upgrade Target
    2. All Computers with Software Update Plug-in Installed Target
    3. All Computers without Software Update Plug-in Installed Target
    4. Linux Computers with Software Update Plug-in Installed Target
    5. Windows Computers with Software Update Plug-in Installed Target

To work on the above second option:

  1. Run the following query to validate the scopes that you have for the above targets:

select i.Name as 'Target',
          t.Name 'Roles',
          case when rt.OwnerTrusteeGuid = '0FFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF'
                   then 'App Identity'
                   else 'Unknown' end as 'Owner',
          rt.OwnerTrusteeGuid,
          rt.LastFullUpdate
  from ResourceTargetOwnerTrustees rtot
    join vRM_Trustee_Item t on t.Guid = rtot.TrusteeGuid
    join Item i                         on i.Guid = rtot.ResourceTargetGuid
    join resourcetarget rt       on rt.Guid = rtot.ResourceTargetGuid
where ResourceTargetGuid in
          ('96F806F1-D46D-47AA-BB40-2E2E5EFBF4C3',
          'F74F662B-F586-457A-9A2E-804CC8F347E5',
          '7C8FCA03-3B41-4A82-A936-FD632B2EDCDA',
          '9E95B894-FC55-4C66-98D0-90C6403EEE2B',
          '9ED1C8F2-0FB6-45EF-AAE6-69285E48C949')
order by i.name, t.name

As an example, if you want to add the Symantec Administrator to "Windows Computers with Software Update Plug-in Installed Target":

  1. Run the following query to enable the target to be editable:
    1. update item set attributes = 0 where guid = 'F74F662B-F586-457A-9A2E-804CC8F347E5'
  2. Go to Console > Settings > All Settings > Software > Patch Management > Windows System Assessment Scan > Select the target > Edit
    1. The target that should be showing above is the "Windows Computers with Software Update Plug-in Installed Target"
  3. At the top right corner, you will see "Scoping" and the name of the scopes that the target is assigned to.
  4. Click on the scopes and add the Symantec Administrator.
  5. Click ok and save the Windows Assessment Scan policy
  6. Run the following query to disable the target to be editable:
    1. update item set attributes = 274 where guid = 'F74F662B-F586-457A-9A2E-804CC8F347E5'
  7. Update the target and see if that fixed the issue

If you need to change the other targets, here are some useful information information of GUID & Target names:

  • 9E95B894-FC55-4C66-98D0-90C6403EEE2B - All Computers requiring Software Update Plug-in Upgrade Target
  • 7C8FCA03-3B41-4A82-A936-FD632B2EDCDA - All Computers with Software Update Plug-in Installed Target
  • 96F806F1-D46D-47AA-BB40-2E2E5EFBF4C3 - All Computers without Software Update Plug-in Installed Target
  • 9ED1C8F2-0FB6-45EF-AAE6-69285E48C949 - Linux Computers with Software Update Plug-in Installed Target
  • F74F662B-F586-457A-9A2E-804CC8F347E5 - Windows Computers with Software Update Plug-in Installed Target