e2e_appmon is not able to start the browser via the probe to run the script
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e2e_appmon is not able to start the browser via the probe to run the script

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Article ID: 196100

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Recently we started moving our scripts to Windows 10 and though setting-wise both machines look identical to me, the same script on Windows 10 is not able to start the browser, it runs well when run through Nimrecorder, but does not run when trying to run the script through the probe.

Error at line n: cannot start the browser.

Environment

  • Release: DX UIM 9.2.0
  • Component: UIM - E2E_APPMON 2.52 or higher
  • e2e_appmon
  • e2e_appmon_dev
  • IE11/MS Edge

Cause

  • WTBho class needed to be enabled

Resolution

Enabling the WTBho class (32bit) allows the test to execute and the browser to start for tests as well.

IE 11 should work fine as long as you review and follow the requirements, so please refer to this link and the comments regarding WTBho.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/monitoring/systems-and-service-response/e2e-appmon-e2e-application-response-monitoring/e2e-appmon-e2e-application-response-monitoring-release-notes.html#concept.dita_ebd496f3c6e00a1d55e04d9e8d1756727f7c2fa7_ProbeSpecificHardwareRequirements

...

Refer to the section-> Enable WTBho Class
For successfully executing web-based scripts, enable WTBho Class, a NimRecorder add-on, on Internet Explorer, Mozilla Firefox, and Google Chrome.
etc
etc...

Microsoft Edge

The following step needs to be confirmed on the machine:

For our Web functions, we load our browser extension. So you need to activate it manually if you plan to use WinTask Web functions. You can activate in the browser main menu, by selecting Tools option, then Internet options item; click Advanced Tab and check the button called

"Enable third-party browser extensions (requires restart)."

Then close MS Edge browser and start it again.

If the error still occurs or the browser or script hngs then check that the following is enabled: