Is the PAM A2A jdbc jar compliant with JDBC specification 4.0?

book

Article ID: 196057

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM) CA Privileged Access Manager - Cloakware Password Authority (PA) PAM SAFENET LUNA HSM CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

PAM A2A is being deployed, but it is a requirement that the JDBC drivers are compliant with JDBC specification 4.0. Is the PAM A2A jdbc jar (cloakwareJdbc.jar) compliant with JDBC specification 4.0?

Resolution

The jar file does not contain JDBC drivers, it acts as a proxy between PAM and the JDBC drivers used in the environment. If the drivers in the environment are are compliant, then there will be no problem.