Errors in System status after upgrade of CA Performance Management (CAPM)
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Errors in System status after upgrade of CA Performance Management (CAPM)

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Article ID: 196002

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

After upgrading CAPM to NetOps 20.2, the upgrade went fine with no errors, but the system status page shows one of the data collectors has the polling status as "Not Connected". However, the DC is running so what is the issue here?

Environment

Release : 20.2
Component : IM Reporting / Admin / Configuration

Cause

The polling status is driven off a JMS (Java messaging system internal to the JRE) message from the DC to the DA. We setup the message producer with an message expiration so that we don't fill up the queue because the DC will keep sending it and we want to avoid a flood of messages when the DA and DC reconnect.

However, if the times between the DC and DA broker (activeMQ) are off, then the message will never get sent because AMQ thinks its expired already.

Resolution

Check the Data Collector (DC) system time since if it's off from the Data Aggregator (DA), then this will happen. Also, check DA system time, in case the DC is right and DA is incorrect, which can also cause this.  If you do find the system times to be off, then do the following:

  • shutdown DC (service dcmd stop)
  • shutdown AMQ broker (service activemq stop)
  • correct the system time
  • start AMQ broker (service activemq start)
  • start DC (service dcmd start)




Additional Information

Note that this can also be seen post-upgrade, not just right after an upgrade, when the Data Aggregator and Data Collector clocks are not in sync.