qos_processor v9.10 Monitor update failed errors

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Article ID: 195989

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Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

The qos_processor probe is throwing a number of errors including numerous 'Monitor update failed...' errors.

Jul 27 15:27:22:834 [Qos Monitor Database Updater #1, qos_processor] Monitor update failed for 'D31BBB9CB1FF0235AE61CA2195A9D2E5CA52549A-wp000215: The connection is closed.
Jul 27 15:27:22:834 [Qos Monitor Database Updater #1, qos_processor] Monitor update failed for '3637CEEE2701971F3C73AB7CAB367354E561C65E-wp000215: The connection is closed.
Jul 27 15:27:22:834 [Qos Monitor Database Updater #1, qos_processor] Monitor update failed for 'ACFFB804E332E5C7D71BD8161A682444B44EE2A4-wp000215: The connection is closed.
Jul 27 15:27:22:834 [Qos Monitor Database Updater #1, qos_processor] Monitor update failed for '5021596972AE114F38F09BED9A873DA3E7981AB0-wp000215: The connection is closed.
Jul 27 15:27:22:834 [Qos Monitor Database Updater #1, qos_processor] Monitor update failed for '331FCE47E23B7872737F86EC524A0DF8F059C59B-wp000215: The connection is closed.

Cause

- qos_processor issue

Environment

Release : 9.2.0

Component : UIM - HUB

Resolution

Download all of the probe packages listed below first into your local archive, then

- Deploy data_engine_9.20_HF5.zip
- Deploy sla_engine_9.10_HF2.zip
- Deactivate the qos_processor probe in the UIM server.
- Deploy qos_processor-9.1.0-HF1.zip
- Empty the queue a number of times

- Run the following sql statement (which may take up to 10 mins) in MS SQL Server Studio
===================================

update qos_data
set checksum = CONVERT(VARCHAR(41),HashBytes('SHA1', convert(varchar(1024),
CONCAT(qos_data.qos,'#',qos_data.source,'#',qos_data.target,'#',qos_data.origin))),2)
FROM S_QOS_DATA qos_data
INNER JOIN S_QOS_DATA T on qos_data.table_id = T.table_id
        and T.checksum!=CONVERT(VARCHAR(41),HashBytes('SHA1', convert(varchar(1024),
CONCAT(qos_data.qos,'#',qos_data.source,'#',qos_data.target,'#',qos_data.origin))),2);

===================================
Via the hub Status Tab, empty the qos_processor message queue again,

- Set the qos_processor loglevel to 5

- Activate the qos_processor

- Check the qos_processor logs to make sure there are no more entries indicating corrupt checksums.