Hub crashing after applying hub 9.20HF16, and robot 9.20HF15

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Article ID: 195972

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Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

Hub crashing after applying hub 9.20HF16, and robot 9.20HF15.

Log Name:      Application
Source:        Application Error
Date:          7/24/2020 8:25:12 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxx.xxxxx.com
Description:
Faulting application name: hub.exe, version: 0.0.0.0, time stamp: 0x5ee87243
Faulting module name: ucrtbase.DLL, version: 10.0.14393.2990, time stamp: 0x5caeb96f
Exception code: 0xc0000005
Fault offset: 0x0000000000022a76
Faulting process id: 0x1958
Faulting application start time: 0x01d661b4e11ac7f2
Faulting application path: f:\Program Files (x86)\Nimsoft\hub\hub.exe
Faulting module path: C:\Windows\SYSTEM32\ucrtbase.DLL
Report Id: b7f954fd-cda8-11ea-949b-005056a146f7
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2020-07-24T12:25:12.000000000Z" />
    <EventRecordID>427009</EventRecordID>
    <Channel>Application</Channel>
    <Computer>WP000210.bcbst.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>hub.exe</Data>
    <Data>0.0.0.0</Data>
    <Data>5ee87243</Data>
    <Data>ucrtbase.DLL</Data>
    <Data>10.0.14393.2990</Data>
    <Data>5caeb96f</Data>
    <Data>c0000005</Data>
    <Data>0000000000022a76</Data>
    <Data>1958</Data>
    <Data>01d661b4e11ac7f2</Data>
    <Data>f:\Program Files (x86)\Nimsoft\hub\hub.exe</Data>
    <Data>C:\Windows\SYSTEM32\ucrtbase.DLL</Data>
    <Data>b7f954fd-cda8-11ea-949b-005056a146f7</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

Cause

- hub probe package dependencies not fully installed or somehow corrupted

Environment

Release : 9.2.0

Component : UIM - HUB

Resolution

Reinstall the following 'vs' packages via the Windows Control Panel:

vs2017_vcredist_x64 1.01
and
vs2017_vcredist_x86 1.01

Then reboot the Primary hub.

After redeployment of the hub and robot, there were no hub crashes within ~24+ hours when it had been crashing periodically every few hours.