DLP Agent installation fails with error "action: failed to open watchdog service -- result: Access is denied"
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DLP Agent installation fails with error "action: failed to open watchdog service -- result: Access is denied"

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Article ID: 195826

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Updated On:

Products

Data Loss Prevention Endpoint Prevent

Issue/Introduction

DLP Agent installation fails with an error "action: failed to open watchdog service -- result: Access is denied"

 

Environment

15.1 and above.

Cause

Remnants of DLP agent registry entry in the Windows Installer Database causing the installation to fail.

Resolution

  • Open the registry editor on the affected system by going to Start > Run > regedit
  • Navigate to Computer\HKEY_CLASSES_ROOT\Installer\UpgradeCodes\A7288D8F16C4659468C66EA6B6030E2A
  • Backup this registry by right clicking on the registry path > Export > Selected Branch > Save to the desired location.
  • Delete the registry entry manually by right clicking on the registry path > Delete
  • Reinstall the agent.

 

Note - This registry entry is not removed by the Clean agent tool and hence requires a manual cleanup.

Additional Information

Ref UpgradeCodes, 

  • {B943D541-EE21-4D78-987E-AC13C9FE5614}
  • {E1FC1869-42BF-4F0B-A835-0D131E31D62B}