MSP: ETC /Remaining Work missing when opening a project from Clarity due to MSP Update not being installed

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Article ID: 195504

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

MSP / Microsoft Project - When exporting projects from Clarity to MSP, it's not retaining ETC hours

Cause

  • This issue can happen due to the latest MSP Supported Update not being installed on the workstation.
  • At a minimum, in MSP New Driver 14.4 and higher, the February 2016 Update is required, but it's best to be on the latest supported MSP Update as that contains the most fixes
  • If you are on the New Driver for 14.1, 14.2, or 14.3, make sure that you do not have any MSP Updates installed as this can cause issues on those versions. 

Environment

Release : All Supported Releases

Component : CA PPM SAAS MICROSOFT PROJECT (MSP)

Microsoft Project MSI versions

MSP New Driver for Clarity

Resolution

  • If you are using the MSP New Driver for CA PPM 14.4 or higher, ensure the latest supported Microsoft Project update is installed on the workstation (see: KB000011553).
  • While the February 2016 Microsoft Project update is the minimum required KB when working with the MSP New Driver in 14.4 or higher, there have been multiple fixes by Microsoft Project in later updates, so it's recommended to be on the latest supported update. 

    Notes:
  • Microsoft Project updates are not supported with the MSP Legacy Driver on any Clarity version. 
  • Microsoft Project updates are not supported in 14.3 or lower in the MSP New Driver. (If you have any Microsoft Project updates installed with 14.3 or lower, this can cause data issues)

Additional Information

  • If the above isn't the cause of your issue, see also: 95395 - MSP New Driver: ETC Hours/Remaining Work missing for tasks with Assignments when opening a project from PPM

  • Clarity and MSP integration known defects - Support Technical Document Index (KB: 15956)

  • Clarity and MSP integration - List of knowledge documents (KB: 71385)

  • See KB: 141061 for tips on how to optimize use of Self Service for Clarity PPM