Oracle Encryption dbms_obfuscation_toolkit.md5 configuration

book

Article ID: 195461

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

We found the below statement in your release documentation

Change Impact and Upgrade

Cannot Upgrade on Oracle Until Security License and MD5 Package Are Enabled Contact your database administrator or Oracle to obtain the advanced security license (OAS) required only if using DBMS_CRYPTO. Enable and grant explicit permissions to dbms_obfuscation_toolkit.md5 (also provided with your Oracle installation). Start the upgrade. 


1) How do we determine if we are using DBMS_CRYPTO?
2) How do we grant the permissions to dbms_obfuscation_toolkit.md5? 

Environment

Release : All Supported Clarity releases

Component : CA PPM INTEGRATIONS & INSTALLATIONS

Resolution

1. dbms_obfuscation_toolkit.md5 is only used if you are using Oracle Encryption. You have to check with your DBA to find out if it's used.

2. Check with your Oracle DBA to enable the permissions if Enrcyption is enabled, they should be aware how to do it if needed. You may refer to the below KB with more steps:

https://knowledge.broadcom.com/external/article?articleId=124905

 

Alternatively, ask the DBA to contact Oracle Support for assistance. We have limited information as this is a third party product not directly supported by us, we only provide information on what's required for it to work with Clarity.