Jasper Report - 'rptParamConn' does not exist
search cancel

Jasper Report - 'rptParamConn' does not exist

book

Article ID: 195402

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

When trying to run a report you get the below error:

ERROR [com.netegrity.webapp.page.reporting.pages.JasperReportTabPage] (default task-62) jdbc connetion object : 'rptParamConn' does not exist - can not run report java.lang.StringIndexOutOfBoundsException: String index out of range: -1

Environment

Release : 14.x

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

This can happen when you manually edit or alter the data source within Jasper Report Server

Resolution

In Jasper Server

  1. Delete the organization
  2. Create a new organization named IAM
  3. Create your user against the IAM organization
  4. Import the CA Identity Manager Reports zip file into Jasper

    There are 2 types of zip file, i.e. Jasper_sql_reports.zip and Jasper_oracle_reports.zip under "IAM Suite\IdentityManager\tools\imreport\ReportDefinitions\IM Standard Reports" directory.

    We need to import Jasper_oracle_reports.zip if the snapshot database is running on Oracle.
    We need to import Jasper_sql_reports.zip if the snapshot database is running on MS SQL.

  5. Adjust permissions at the IAM level setting your created user from step 3 with read only access
  6. Navigate down to IAM > IM > datasources and right click datasources
  7. Set the permissions on the datasources folder as read + write for the user created in step 3. DO NOT EDIT THE DATASOURCE
  8. Navigate to IDM and create your snapshot.  
  9. Once the snapshot is created, request the report.  When you request the report, the datasource will be updated on Jasper Server. 

Additional Information

IDM modifies the data source when you request the report.