Traces are set to 7 days on Collectors , only able to see traces for 3 or 4 days
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Traces are set to 7 days on Collectors , only able to see traces for 3 or 4 days

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Article ID: 195285

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction



There are no 7 days traces in the Console , we are losing the data. the data is available in APM is up to 3 to 4 days only.



Environment

Release : 10.7.0

Component : APM Agents

Cause

traces database is kept based on two factors:

1. introscope.enterprisemanager.transactionevents.storage.max.data.age=

2. The apm-events-thresholds-config.xml in the /config folder of each Enterprise Manager has a clamp on the amount of disk space used by trace events.

introscope.enterprisemanager.transactionevents.storage.max.disk.usage

When one of the above categories is met, the traces db will be removed. 

Resolution

Unfortunately the deleted traces DB cannot be retrieved. We can only prevent going forward.  we have two options,

1. increase the space for each collector and make the value synced up across all EMs.  Restart of EM is required. 

<clamp id="introscope.enterprisemanager.transactionevents.storage.max.disk.usage">
            <threshold value="####"/>
        </clamp>

2. Reduce traces from Agents who reports way too many traces