ROBOT FOR SUSE LINUX ENTERPRISE SERVER 12 SP5 fails to install

book

Article ID: 195260

calendar_today

Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction


we need to install a Nimsoft robot to this version of OS: SUSE Linux Enterprise Server 12 SP5



here is the controller log:

Jul 14 11:55:37:900 [139752283150080] Controller: Could not figure out what Linux version you are running!

Jul 14 11:55:37:900 [139752283150080] Controller: Please report the following system information to [email protected]

Jul 14 11:55:37:900 [139752283150080] Controller: System information:

Jul 14 11:55:37:900 [139752283150080] Controller:   sysname:  Linux

Jul 14 11:55:37:900 [139752283150080] Controller:   node   :  xxxxxxxxxxxxx

Jul 14 11:55:37:900 [139752283150080] Controller:   release:  4.12.14-122.26-default

Jul 14 11:55:37:900 [139752283150080] Controller:   version:  #1 SMP Wed Jun 17 11:17:05 UTC 2020 (5c515dc)

Jul 14 11:55:37:900 [139752283150080] Controller:   machine:  x86_64

Jul 14 11:55:37:900 [139752283150080] Controller: inst_pkg - warning, no compatible package sections found for package 'robot_update'

Environment

Release : 20.1

Component : UIM - ROBOT

Resolution

workaround:

create a robot package without containing the OS tags in OS detection.