UIM Primary hub is down after deploying wrong hub hotfix

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Article ID: 195248

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Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

My UIM primary hub is down and cannot connect. Also the secondary hub is not connecting and is totally unreachable. This issue started since I have a deployed a hub hotfix 9.1HFx on my UIM 9.2 with hub version 9.2. 

As a consequence, also my UMP does not come up and wasp is down. 

Cause

Since the wrong hotfix hub 9.1Hfx has been deployed on UIM 9.2 which requires minimum hub 9.2, the hub folder has corrupt.

From the hub folder, the hub.log, hub.cfg and security.cfg were no longer present. Hence the primary controller could not establish connection and the entire UIM was down. 

Environment

Release : 9.2.0

Component : UIM - HUB

Resolution

In this scenario there are 2 possible options to fix the UIM issue:

 

•   Restore the UIM system from a backup image that was taken before deploying the wrong fix

or

•   Re-run the UIM installer of the same version. This will overwrite and patch the missing important files from the hub folder and the issue should be fixed. 

 

After fixing the primary hub (i.e Reinstalled UIM) you may also have to reimport the certificate.pem file to the UMP server and CABI Server:

Copy from the primary hub the certificate.pem (from the security under the nimsoft folder) to the location defined in the UMP server robot.cfg:

Example:

cryptkey = C:\Program Files (x86)\Nimsoft\security\certificate.pem

 

 

Additional Information

Current UIM hub and version compatibility list

https://knowledge.broadcom.com/external/article?articleId=185786