HTTPS error on admin console - NET::ERR_CERT_COMMON_NAME_INVALID
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HTTPS error on admin console - NET::ERR_CERT_COMMON_NAME_INVALID

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Article ID: 195162

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We are getting an SSL error on admin console when setting up https

NET::ERR_CERT_COMMON_NAME_INVALID 
This server could not prove that it is uimserver.dev.mydomain.com; its security certificate does not specify Subject Alternative Names. 
This may be caused by a mis-configuration or an attacker intercepting your connection.

Environment

Release : 9.2.0 or later

 

Cause

It looks like the common name should have be the FQDN of the webserver or could be a browser related issue

Resolution

1. Clear browser cache, restart browser, also you may import the certificate to the browser

2. Make sure the common name should have be the FQDN

3. Put the key parameters on keytool, for ending security warnings on admin console.

             keytool -genkeypair -alias wasp -keyalg RSA -keysize 4096 -ext san=dns:<myuimserver>.example.<mydomain>.com,ip:##.##.##.## -keystore wasp.keystore -validity 730

             keytool -certreq -alias wasp -validity 730 -keystore wasp.keystore –ext san=dns:<myuimserver>.example.<mydomain>.com,ip:##.##.##.##  -file dev.mydomain.com.csr

 

You may restart wasp probe to refresh, now Admin console is https error free, after adding settings for SAN on the certificate creation