Not able to Approve/Reject a work item in the Identity Manager
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Not able to Approve/Reject a work item in the Identity Manager

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Article ID: 195110

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

When a user tries to Approve/Reject a work item from "View My Work List" receives an error message:


"Error: Cannot create a task session for the approval task."

Environment

Identity Manager 14.x

Cause

Some information was deleted from Task Persistence database, the option is to update the WorkPoint database manually.

Resolution

Right-click on work-item you want to remove and select Copy Link Address, and paste it in a notepad

1. Confirm url for the request event in worklist
e.g.https://<IdM-Server>/iam/im/identityEnv/ui7/index.jsp?task.nest.wfitem=1+4+79%3AWPDS
note down the value between 'task.wfitem=1+4+' and '%3AWPDS'.
in above case, the value is 79.

2. Connect to database and run following SQL to check the record
select * from WP_WORK_ITEM where ACTI_ID=79;

3. run following SQL to update the record ( work_state_id=5 means complete)
update WP_WORK_ITEM set work_state_id=5 where ACTI_ID=79;

commit;

Additional Information

If you have the same problem in the Identity Portal, see the KB article below:

https://knowledge.broadcom.com/external/article/279355