Error Installing APM for SSO on Linux Policy Server

book

Article ID: 195098

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

When trying to install CA APM for SSO agent on a Linux policy server, It does not detect the NETE_PS_ROOT variables. I am installing on a policy server, which already has this variable set 
I always get the warning as below and it does not allow me to go forward.
Warning
-------
CA APM SSO Environment Variables NETE_WA_ROOT/NETE_PS_ROOT not set
PRESS <ENTER> TO ACCEPT THE FOLLOWING (OK):
Error in the installer log.
=================================================================================

Execute Script/Batch file:   Check if PS or WA is installed
                          Status: ERROR
                          Additional Notes: ERROR - Error while attempting to execute the installation script
================================================================================== 

Environment

Release : 13.2

Component : APM Agents

Resolution

After reviewing the /tmp directory, it was found that the script to check for the existence of the 2 above properties was not being executed.  Set IATEMPDIR to another directory and customer was able to get past this install issue.