MySQL Security Vulnerability upgrade to 5.6.40

book

Article ID: 195047

calendar_today

Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

We are using MySQL 5.6.x on which multiple Vulnerabilities (RPM Check) reported details below.

Description:

The-remote-database-server-is-affected-by-multiple-vulnerabilities.
The-version-of-MySQL-running-on-the-remote-host-is-56x-prior-to-5640-It-is-therefore-affected-by-multiple-vulnerabilities-as-noted-in-the-April-2018-Critical-Patch
Remediation:
Upgrade-to-MySQL-version-5640-or-later-For-more-details-please-refer-to-Notes-and-attachment-in-the-work-details

We want to check if there is an issue to upgrade to MySQL 5.6.40

 

Environment

Release : 6.4, 6.5, 6.6, 6.7

Component : CA RELEASE AUTOMATION CORE

MySQL: 5.6.x

Resolution

We tried to check from our end and we believe that a minor upgrade to 5.6.40 should not cause issue for Release Automation. However, this is something from review so we will recommend to do it with some diligence at your end with help of your Database administrator, if needed urgently.