Scan in progress doesn't go away

book

Article ID: 195018

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction


On the TDM portal my colleague tried the data model scan against another DB and had the same results - “Scan in progress” indicator remains on the Data Model screen and never goes away. That being said, he was able to create a data generator. He also tried some data modelling work around masking and had the same problem with the screen continuing to show scanning (Until he cancelled it). In each case, he was able to go to next steps after cancelling and everything seemed to work. Could you please investigate why this issue exists and what could be done to resolve it?

Cause

 

You need to add support for websocket. information taken from https://www.happyassassin.net/posts/2018/11/23/reverse-proxying-websockets-with-apache-a-generic-approach-that-works-even-with-firefox/

Make sure to enable proxy_wstunnel_module

 

<VirtualHost *:443>
  ServerName tdm-test.COMPANY.com
  SSLEngine on
  SSLProxyEngine on
  SSLCertificateFile "E:\Apache24\keys\tdm-test_COMPANY._com_cert.cer"
  SSLCertificateKeyFile "E:\Apache24\keys\tdm-test.COMPANY..com.key"
  SSLProxyVerify none
  SSLProxyCheckPeerCN off
  SSLProxyCheckPeerName off
  SSLProxyCheckPeerExpire off
 
  ProxyPass / http://localhost:8080/
  ProxyPassReverse / http://localhost:8080/
 
  ProxyRequests off
 

    RewriteEngine on    RewriteCond %{HTTP:Upgrade} websocket [NC]    RewriteCond %{HTTP:Connection} upgrade [NC]    RewriteRule .* "ws://localhost1%{REQUEST_URI}" [P]

  ProxyPass        /TestDataManager/apihttp://localhost:8080/TestDataManager/api
  ProxyPassReverse /TestDataManager/api http://localhost:8080/TestDataManager/api
  ProxyPass        /TestDataManager/user http://localhost:8080/TestDataManager/user
  ProxyPassReverse /TestDataManager/user http://localhost:8080/TestDataManager/user
  ProxyPass        /TestDataManager http://localhost:8080/TestDataManager
  ProxyPassReverse /TestDataManager http://localhost:8080/TestDataManager
  ProxyPass        /TDMConnectionProfileService http://localhost:8080/TDMConnectionProfileService
  ProxyPassReverse /TDMConnectionProfileService http://localhost:8080/TDMConnectionProfileService
  ProxyPass        /tdmJobEngineService http://localhost:8080/tdmJobEngineService
  ProxyPassReverse /tdmJobEngineService http://localhost:8080/tdmJobEngineService
  ProxyPass        /TDMProjectService http://localhost:8080/TDMProjectService
  ProxyPassReverse /TDMProjectService http://localhost:8080/TDMProjectService
  ProxyPass        /TDMService http://localhost:8080/TDMService
  ProxyPassReverse /TDMService http://localhost:8080/TDMService
  ProxyPass        /tdmwebModelingService http://localhost:8080/tdmwebModelingService
  ProxyPassReverse /tdmwebModelingService http://localhost:8080/tdmwebModelingService
 
  LogFormat "%h \"%{BALANCER_WORKER_NAME}e\" %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-agent}i\"" custom
  CustomLog logs/proxy-access.log custom
</VirtualHost>

Environment

Release : 4.9

Component : CA Test Data Manager

Resolution

I have changed
RewriteRule .* "ws://localhost1%{REQUEST_URI}" [P]
to
RewriteRule /(.*) "ws://localhost:8080/$1" [P]

I am including my httpd config file for reference

Attachments

1594670893752__httpd.conf get_app