PRD: Some Agents are not connecting properly to AE.

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Article ID: 194799

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Agent does not connect and stop generating anything else on the agent log until the agent was shut down by Service Manager or by killing the Agent process. While in this state, AWI shows it as inactive and will not run jobs.

20200709/101228.868 - U02000004 Connection to Server 'UC4PRD#CP005(ID=3)' successfully created.
20200709/101228.868 - U02000354 CP Server 'UC4PRD#CP005' reports ranking '1'.
20200709/101228.874 - U02000073 Connection to system 'UC4PRD' via CP Server '' successfully established.
20200709/101228.879 - U02000066 Host information: Host name='agentname, IP address='127.0.0.1'

Trying to restart the CP on which the agent is connected to does not seem to resolve the issue.

Cause

Looking at the log of the CP to which the agent is connected to.

20200709/142151.973 - U00003412 Agent 'agentname' logged on (Client connection='2202').
20200709/142151.983 - U00003366 Connection to agent 'agentname' already exists (old connection '*CP003#00004656', new connection '*CP004#00002202').

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Resolution

The following workaround can be used if you encounter this issue:

1. Stop JCP
2. Delete agent -> From AWI-> Client 0 -> Administrations-> Agents-> right click on the agent and choose Delete
3. Restart agent from Service Manager Dialog (or command line).
4. Start JCP

This will be fixed in a future release