Devices with extremely large configurtion sizes are not being backed up in NCM using SSH / SCP

book

Article ID: 194720

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

For some of the devices in Spectrum that have very large configurations using SSH / SCP, Spectrum is unable to capture all the configuration. How can I capture the configurations of these devices?

Cause

Need to increase the timeout settings so that entire config can be captured

Environment

Release : 10.3.x / 10.4.x

Component : Spectrum App / NCM

Resolution

Make a backup of the $SPECROOT/NCM/config.xml file

Edit the $SPECROOT/NCM/config.xml file. Look for the following two lines:

    <ssh-library type="java.lang.String">mindterm</ssh-library>
    <jsch-read-datawait type="java.lang.Integer">8</jsch-read-datawait>

Change them to read as follows:

    <ssh-library type="java.lang.String">jsch</ssh-library>
    <jsch-read-datawait type="java.lang.Integer">32</jsch-read-datawait>

Kill the current running ncmservice process. processd will start a new one.

NOTE: mindterm and 8 are the default values for these two parameters. You may have to reapply these changes after an upgrade.

Additional Information

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/10-4-2/managing-network/network-configuration-manager/network-configuration-manager-configurations/network-configuration-manager-extension-utility.html#concept.dita_365f06e2315d5d81950a2d485914292dc36c4aa3_NCMSupportforSSHusingJschlibraries