Registry Service will not start on Windows Server in Azure - fails on derby database start-up
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Registry Service will not start on Windows Server in Azure - fails on derby database start-up

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Article ID: 194573

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Updated On:

Products

CA Cloud Test Mobile CA Application Test

Issue/Introduction

My DevTest instance  is on a Windows 10 Enterprise Server running in Azure.  It was running just fine for months until last week. Then it failed and is throwing an error while trying to start the registry service. It is using the internal derby database. Strangely, running the registry component from the command line works fine!  The error is only encountered when running the Registry Service. I have blown away the entire DevTest install and re-installed from scratch and I still get the same error.  The error is below and I will also be attaching the registry.log.  The user is trying to get some critical testing done so the sooner we can resolve this, the better.

2020-07-02 04:47:21,772Z (23:47) [main] ERROR com.itko.lisa.utils.JpaUtil    - Exception raised checking table existence: Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.3.2.v20111125-r10461): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: java.sql.SQLException: Connections could not be acquired from the underlying database!
Error Code: 0
javax.persistence.PersistenceException: Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.3.2.v20111125-r10461): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: java.sql.SQLException: Connections could not be acquired from the underlying database!
Error Code: 0

 

 

When you start Registry as a Service,  you are getting the error " java.sql.SQLException: Connections could not be acquired from the underlying database! "   

lisa.db  ( derby database) does not get created. 

When you start Registry as Server ( executable) it works fine.  lisa.db is created and Registry starts fine

Environment

Release : 10.5

Component : CA Application Test

Cause

 

The local security policy changed on the Windows services. The account needs the "Log on as a service" right, which services.msc grants automatically.

Resolution

Manually added the logon User for the Registry Service .  Also check with your security team what policies changed on the Windows services as you did not have to do this before. 

Additional Information

 

Manually added the logon User  for the Registry Service (Rt -Click on Registry Service- Logon ->This Account)  and then started the Service. This worked.

Check with your security team what policies changed on the Windows services as you did not have to do this before.