TDM 4.9.53 log running completed Job is not being communicated to other parts of services and jobs are queueing

book

Article ID: 194566

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Issue I can a see  (7/3/2020)  job 3627 completed in Publish Engine but it's message back to Job Engine or where ever that the  completed  isn't being picked up or arriving to complete the Cycle. Jobs takes about 10-15 minutes.


Here is the Job Engine saying it started and the below is publish saying it sent back and gets a 200 from the Job engine. 


2020-07-03 16:30:43.349 UTC [INFO ] [https-openssl-nio-8443-exec-11] --- [U:JOSHR2E][M:POST][P:/api/ca/v1/jobs]                                  c.c.t.s.LDAPUtil:  isUserModified:false
2020-07-03 16:30:43.349 UTC [INFO ] [schedulerFactoryBean_Worker-6] --- [U:][M:][P:]                               c.c.t.j.job.BaseJob:  Job started with name: CreateCustomerData_vDeals Data Request id: 3626
2020-07-03 16:30:43.349 UTC [INFO ] [https-openssl-nio-8443-exec-11] --- [U:JOSHR2E][M:POST][P:/api/ca/v1/jobs]                     c.c.t.s.s.SecurityUserService:  Begin::getUserAccessibleFunctions()
2020-07-03 16:30:43.349 UTC [INFO ] [schedulerFactoryBean_Worker-6] --- [U:][M:][P:]                              c.c.t.j.job.GroupJob:  Group job execution started 
2020-07-03 16:30:43.350 UTC [INFO ] [https-openssl-nio-8443-exec-11] --- [U:JOSHR2E][M:POST][P:/api/ca/v1/jobs]                     c.c.t.s.s.SecurityUserService:  Begin::loadGroups()
2020-07-03 16:30:43.353 UTC [INFO ] [schedulerFactoryBean_Worker-6] --- [U:][M:][P:]                           c.c.t.j.u.SchedulerUtil:  The next job trigger starting is  CreateCustomerData_vDeals Data Request_&&_&&_3627
2020-07-03 16:30:43.354 UTC [INFO ] [https-openssl-nio-8443-exec-11] --- [U:JOSHR2E][M:POST][P:/api/ca/v1/jobs]                     c.c.t.s.s.SecurityUserService:  End::loadGroups()
2020-07-03 16:30:43.362 UTC [INFO ] [https-openssl-nio-8443-exec-11] --- [U:JOSHR2E][M:POST][P:/api/ca/v1/jobs]                     c.c.t.s.s.SecurityUserService:  Begin::getGroupsMappedToExternalGroupsOfUserByDn()
2020-07-03 16:30:43.363 UTC [INFO ] [https-openssl-nio-8443-exec-11] --- [U:JOSHR2E][M:POST][P:/api/ca/v1/jobs]                                  c.c.t.s.LDAPUtil:  Begin::getLdapGroupsForUserDn()
2020-07-03 16:30:43.388 UTC [INFO ] [schedulerFactoryBean_Worker-6] --- [U:][M:][P:]                               c.c.t.j.job.BaseJob:  executionCompleted CreateCustomerData_vDeals Data Request_&&_&&_3626
2020-07-03 16:30:43.412 UTC [INFO ] [https-openssl-nio-8443-exec-11] --- [U:JOSHR2E][M:POST][P:/api/ca/v1/jobs]                                  c.c.t.s.LDAPUtil:  End::getLdapGroupsForUserDn()

Here the Publish says it completed and got back a HTTP 200, but the Job Engine never sees it.


2020-07-03 16:44:30.352 UTC [INFO ] [taskExecutor-16          ] --- [U:][M:][P:]                           c.c.t.p.l.TDMPublishLog:  End date and time: 2020/07/03 12:44:30
2020-07-03 16:44:35.611 UTC [INFO ] [taskExecutor-16          ] --- [U:][M:][P:]                  c.c.t.p.t.TDMPublishStatusSender:  Successfully sent status update for job 3627 to Job Engine Service, Status Code: 200 OK
2020-07-03 16:44:35.611 UTC [INFO ] [taskExecutor-16          ] --- [U:][M:][P:]                      c.c.t.p.m.TDMPublishJobStart:  doPublish end, jobId=3627

Cause

 

N/A

Environment

Release : 4.9

Component : CA Test Data Manager

Resolution

Open a support case and ask for patch TDMWeb-4.9.65.0.zip.


Additional Information