DX Platform - Unable to login due to password expiration

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Article ID: 194529

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Updated On:

Products

DX Operational Intelligence DX Application Performance Management CA App Experience Analytics

Issue/Introduction

"LOGIN ERROR CODE 2011034"

Cause

Password for users will expire after 180 days

 

How to verify this default setting?

a) obtain the postgres pod name

kubectl get pods -n<namespace> | grep postgres

Example:

kubectl get pods -ndxi | grep postgres
dxi-postgresql-bccdd4475-86z4d                        1/1       Running     0          34d

b) exec postgres pod

kubectl exec -it <postgres-pod> -n<namespace> bash

Example:

kubectl exec -it dxi-postgresql-bccdd4475-88fqw -ndxi bash

 
c) connect to aoplatform database

psql -U aopuser -d aoplatform

 

d) Check default validity Period:

select * from aradminpwdpolicy ;

orgname         | minpasswordlength | maxpasswordlength | minnumericchars | minalphachars | minspecialchars | strikecount | allowedsplchars | isglobal | validityperiod |
 passwordhistcount | isallowall
------------------------+-------------------+-------------------+-----------------+---------------+-----------------+-------------+-----------------+----------+----------------+
-------------------+------------
 --globalorganization-- |                 6 |                25 |               1 |             4 |               1 |           5 | [email protected]#$%^&*()_+    | Y        |            180 |
                 3 | N
 MASTERADMIN            |                 6 |                25 |               1 |             4 |               1 |           5 | [email protected]#$%^&*()_+    | N        |              0 |
                 3 | N
 DEFAULTORG             |                 6 |                25 |               1 |             4 |               1 |           5 | [email protected]#$%^&*()_+    | N        |              0 |
                 3 | N

Environment

DX Operational Intelligence 1.3.x, 20.2.x
DX Application Performance Management 11.x, 20.2.x
DX AXA 20.2.x

Resolution

For 20.2+:

a) If the affected user is the TENANT administrator:

Login to http://<apmservices-gateway>/dxiportal/#/dxiportal/login as MASTERADMIN

Go to Tenant Services, 

Locate your Tenant, click "Configure", change the password


b) For any other user, login as the tenant administrator and change the password:

Login to http://<apmservices-gateway>/dxiportal/#/dxiportal/login as the TENANT administrator user

Go to "USER-MANAGEMENT"

Locate the affected user

Update the password

 

For DOI 13.2:

1. Login to http://adminui.<route host>/admin/ as gadmin

username: gadmin
password: <your password>    (*this is the master password given during installation*)
tenant name: defaultorg

2. Locate the user and update the password

- Select PEOPLE
- Select <your tenant>   

for example, "support" in the below image:

- Select the user, Click "EDIT PROFILE" 

- Click "Change Password"

Additional Information

DX AIOPs - Troubleshooting, Common Issues and Best Practices
https://knowledge.broadcom.com/external/article/190815

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