ARD 3.0 and above unable to connect to TDMService
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ARD 3.0 and above unable to connect to TDMService

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Article ID: 194322

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools) CA Agile Requirements Designer

Issue/Introduction

When trying to connect ARD 3.0 and above to TDMService, getting error message Fault Code Soap Env:Server java.lang.NullPointerException

Environment

Component : CA Test Data Manager - 4.9

Component: ARD - 3.0

Cause

In the TDM Service log file it is seen that mac address is null.

AuthenticateUser - userName: username, osUser: , macAddress: , application: 

Because the mac address value is null, this is causing the exception to occur.  

With ARD 3.0 there is no more license key and the mac address is no longer required/captured.  

Resolution

This issue has been fixed in TDMWeb-4.9.53.0 and above.

Open a support case and request for this build and follow TDM Portal section of below article to apply the patch.

https://knowledge.broadcom.com/external/article?articleId=10931