Messaging Gateway stops processing messages until the appliance is rebooted or the MTA service is restarted
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Messaging Gateway stops processing messages until the appliance is rebooted or the MTA service is restarted

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Article ID: 194273

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Updated On:

Products

Messaging Gateway

Issue/Introduction

You have noticed the Messaging Gateway appliance has stopped processing messages and the Brightmail Engine log has many repeating errors similar to the following:

2020-06-28T12:55:05-06:00 (ERROR:8494.2264913664): [42130] [ <0000000000006a800105a926cd21@domain.dom>] SG Decomposer: Internal engine not initialized.
2020-06-28T12:55:05-06:00 (ERROR:8494.2264913664): [27224] [ <0000000000006a800105a926cd2[email protected]>] An error occurred while decomposing a message.
2020-06-28T12:55:05-06:00 (ERROR:8494.1736435456): [42130] [ <20200628154349.2EC147D7AAC@domain.dom>] SG Decomposer: Internal engine not initialized.
2020-06-28T12:55:05-06:00 (ERROR:8494.1736435456): [27224] [ <20200628154349.2EC147D7AA[email protected]>] An error occurred while decomposing a message.

Environment

Release : 10.7

Component : Brightmail Engine

Cause

This is a known, uncommon issue that can occur in 10.7.3 and previous versions of 10.7 after a malware definition update.

Resolution

This issue has been resolved with the Messaging Gateway 10.7.4 release

Workaround.

For earlier product versions, the issue can be worked around by restarting the MTA service from the command line, or by restarting the appliance.

To restart the MTA service, use the following command using the default admin account at the command line interface of an affected appliance:

service mta restart