Jaspersoft not working: Error HTTP Status 404 – Not Found, Type Status Report

book

Article ID: 194266

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

  • We're installing a new Clarity environment with Jaspersoft 7.1, and we're having issues getting Jaspersoft reports to work. 
  • We get the following error:

    HTTP Status 404 – Not Found, Type Status Report, Message /reportservice/flow.html, Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Cause

This issue can happen when you make changes to any of the Jaspersoft DB connection details including database hostname (after a database move) or database password

Environment

Release :  All Supported Releases

Component : CA PPM JASPERSOFT

Resolution

  1. Change your Jaspersoft Database password using the steps in the following KB: 33318
  2. If you see an error decrypting attribute when trying to restart Jaspersoft Services after the above change, the following commands may need to be run:

admin update jasperParameters

admin jaspersoft syncPPMContext -userName superuser -password superuser

admin content-jaspersoft csk restoreDomains -userName superuser -password superuser