Puppet 3 is required for the OPMS installation, version '5.5.12' found.”

book

Article ID: 194261

calendar_today

Updated On:

Products

CA App Synthetic Monitor NIMSOFT CLOUD USER EXPERIENCE MONITOR DX Application Performance Management

Issue/Introduction

While trying to upgrade to ASM 10.4,  getting this error:
  
 “Puppet 3 is required for the OPMS installation, version '5.5.12' found.”
 
  

Cause

The installation overwrites the puppet version and installs the version 5.

Environment

Release : 10.0

Component : CA APP SYNTHETIC MONITOR (WATCHMOUSE)

Resolution

It looks like a recent Red Hat patch may have installed version 5.5.12 on this server.

 

Additional Information

This is a known issue, please refer the below KB and see. 

ASM OPMS 10.4 upgrade failed, cannot install puppet

On promise station upgrade does not work

Puppet version is replaced by OPMS Installation