OSB monitoring error
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OSB monitoring error

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Article ID: 194251

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

After deploying the Oracle Service Bus agent, the log started to be filled by the below entries and do not show all Oracle Service Bus information.

[ERROR] [IntroscopeAgent.OSB] com.bea.wli.sb.pipeline.RouterContext.getServiceRef()
[ERROR] [IntroscopeAgent.OSB] com.bea.wli.sb.pipeline.RouterContext.getServiceRef()
[ERROR] [IntroscopeAgent.OSB] com.bea.wli.sb.pipeline.PipelineContextImpl.getServiceRef()
[ERROR] [IntroscopeAgent.OSB] com.bea.wli.sb.pipeline.PipelineContextImpl.getServiceRef()

Environment

Application Performance Management Agent 10.7

Cause

This is due to the Oracle Service Bus 12 release being monitored by the 10.7 agent release which is unsupported.

Resolution

In order to monitor Oracle Service Bus 12 release, you must use our extension. By default our 10.7 release is not homologated with Oracle Service Bus 12 per our compatibility guide:

Raise a support ticket and ask for the OSB12 extension for 10.7 agent monitoring.

Additional Information

https://support.broadcom.com/external/content/release-announcements/CA-Application-Performance-Management-Compatibility-Guides/2146