Service hang/unable to login to the manager after upgrade to version 14.3

book

Article ID: 194207

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

After upgrading the manager to version 14.3, resulting deadlocks prevent the login to the console and or other various tasks of the manager to fail and not work.  Restarting the SEPM services, rebooting the SEPM and or restarting SQL services temporarily resolves the issue until it happens again.

Cause

SQL query timeouts observed in the debug logs (Tomcat logging = FINEST, SCM-Server#.log, stdout#.log) that eventually result in deadlocks on the database.  This prevents new tasks and services from functioning.

Environment

2020-06-10 07:20:31.554 THREAD 1 SEVERE: Caused by: java.sql.SQLTimeoutException: The query has timed out.
2020-06-10 07:20:31.554 THREAD 1 SEVERE: at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeStatement(SQLServerStatement.java:226)
2020-06-10 07:20:31.554 THREAD 1 SEVERE: at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeUpdate(SQLServerStatement.java:711)
2020-06-10 07:20:31.554 THREAD 1 SEVERE: at org.apache.tomcat.dbcp.dbcp2.DelegatingStatement.executeUpdate(DelegatingStatement.java:341)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: at org.apache.tomcat.dbcp.dbcp2.DelegatingStatement.executeUpdate(DelegatingStatement.java:341)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: at com.sygate.scm.server.db.util.DatabaseUtilities.getNextUsnInternal_update(DatabaseUtilities.java:1487)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: at com.sygate.scm.server.db.util.DatabaseUtilities.getNextUSN_Update(DatabaseUtilities.java:1401)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: at com.sygate.scm.server.db.util.DatabaseUtilities.getNextUSN(DatabaseUtilities.java:1312)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: at com.sygate.scm.server.db.util.DatabaseUtilities.getNextUsnBySystemProperty(DatabaseUtilities.java:1433)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: at com.sygate.scm.server.metadata.StateMetadataCollection.updateMetadata(StateMetadataCollection.java:162)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: at com.sygate.scm.server.metadata.MetadataManager.updateMetadata(MetadataManager.java:725)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: at com.sygate.scm.server.metadata.MetadataManager.updateMetadata(MetadataManager.java:780)
2020-06-10 07:20:31.570 THREAD 1 SEVERE: ... 49 more
2020-06-10 07:20:31.586 THREAD 1 SEVERE: com.sygate.scm.server.util.ServerException: Unexpected server error.
2020-06-10 07:20:31.586 THREAD 1 SEVERE: at com.sygate.scm.server.configmanager.ConfigManager.updateStateObject(ConfigManager.java:1815)
2020-06-10 07:20:31.586 THREAD 1 SEVERE: at com.sygate.scm.server.configmanager.ConfigManager.updateSemServerStateObject(ConfigManager.java:6724)
2020-06-10 07:20:31.586 THREAD 1 SEVERE: at com.sygate.scm.server.servlet.StartupServlet.registerServer(StartupServlet.java:418)
2020-06-10 07:20:31.586 THREAD 1 SEVERE: at com.sygate.scm.server.servlet.StartupServlet.startServer(StartupServlet.java:629)

 

2020-06-09 18:30:15.406 THREAD 41 SEVERE: java.sql.BatchUpdateException: Transaction (Process ID 104) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.
2020-06-09 21:48:13.927 THREAD 41 SEVERE: com.microsoft.sqlserver.jdbc.SQLServerException: Transaction (Process ID 247) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.
2020-06-10 03:04:20.142 THREAD 41 SEVERE: com.microsoft.sqlserver.jdbc.SQLServerException: Transaction (Process ID 257) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.
2020-06-10 03:55:26.804 THREAD 41 SEVERE: com.microsoft.sqlserver.jdbc.SQLServerException: Transaction (Process ID 163) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.

 

Resolution

This issue is fixed in Symantec Endpoint Protection 14.3 MP1. For information on how to obtain the latest build of Symantec Endpoint Protection, see Download the latest version of Symantec software here.

 

Additional Information

ESCRT-4087