IM Error - Failed to copy checksum file
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IM Error - Failed to copy checksum file

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Article ID: 194179

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

During the deployment of a DR (Disaster Recovery) node on a CA Identity Suite (CA Identity Manager) Virtual Appliance (vApp) the following error is returned and the installation fails.

 

[ERROR] failed to copy checksum file from <IP Address> - error code 1

 

Environment

Release : 14.x

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

Mismatch of CP patch sets between nodes. 

Resolution

This issue will be encountered when the nodes being 'clustered' are at different patch levels. 


To overcome this issue patch the DR vApp with the same OS and VA patches deployed on the Primary node. 

Deploy the components required (ie IM, IP, IG, etc.) on to the virtual appliance (vApp) and when the error code is returned. 

Patch the components to the same level as the 'original' vApp node, and then reboot both nodes.



After the reboot the code 1 error should no longer appear. 

 

 

To check what patches are installed log into the vApp client help page:

https://{vApp_host_IP:10443/vapp/client/#!/help

scroll to the bottom of the page to review was has been applied:

This information can be gathered from the vApp ssh console with the 'rollback_vapp' alias:

This will return a list of all currently applied fixes that can be rolled back:

Select Cancel to close the rollback process. 

Additional Information

For more information on 'Deploying Redundant Systems' (Disaster Recovery nodes), please refer to the product documentation.