Clarity PPM: Timesheet is not Auto-Approved When Entering 0 Hour
search cancel

Clarity PPM: Timesheet is not Auto-Approved When Entering 0 Hour

book

Article ID: 194034

calendar_today

Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

When users submit zero-hour timesheets, the auto-approve process should start and send out an action item.

 

Cause

In reviewing an example further, the timesheet process checks if the hours equals 0 or not equals 0.

When a value, e.g. 0.01 or 0.001 is entered, it will cause the process to unintentionally not auto-approve as it is not equal 0. Since the database stores the values as not 0, the process instance will not kick off.

 

Resolution

To prevent the issue, review process condition to check if the hours are > 0 (greater than zero).