Unable to start CA SSO R12.8 Policy server

book

Article ID: 194007

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) SITEMINDER

Issue/Introduction

 

We're starting the Policy Server and this one doesn't get into the
memory. We see no smps.log nor smexec.log produced.

This issue happens after having patched the OS.

How can we fix this ?

 

Cause

 

We ran strace against the start-ps script, and the output was as the
following :

run.dump.275382

  15:47:56 execve("/opt/CA/siteminder/start-ps",
  ["/opt/CA/siteminder/start-ps"], 0x7ffc8f1ba360 /* 21 vars */) = -1
  ENOEXEC (Exec format error)

 

Environment

 

  Policy Server 12.8SP2 on RedHat 7;

 

Resolution

 

Insure that the script /opt/CA/siteminder/start-ps is not empty and
has the correct (out-of-the-box) code to start the Policy Server and
fix the issue.