Configuration service not available (please reboot)
book
Article ID: 194004
calendar_today
Updated On:
Products
CA API Gateway
Issue/Introduction
The "Manage status" or "Create/Configure API Gateway database" from the Gateway Configuration Menu in ssgconfig returns this error.
Configuration service not available (please reboot)
Environment
All supported versions of the CA API Gateway
Cause
Incorrect host IP address in hosts.properties file
Improper SSPC log file permission/owner/group
Gateway service (SSG) cannot start
Resolution
Update /opt/SecureSpan/Controller/etc/host.properties file with the correct IP address of the Gateway node.
host.controller.sslIpAddress=XXX.XXX.XXX.XXX
Restart gateway service
Check /opt/SecureSpan/Controller/var/logs/sspc_0_0.log file owner/group, it should be layer7/layer7. If not, change owner/group to layer7/layer with RW permission for both owner and group. Also, check the logs directory and its parent directory's owner/group to make corrections if necessary.
If the file owner/permission has been changed, restart the gateway service.