Error: Unable to initiate the process XXX, please contact the administrator.
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Error: Unable to initiate the process XXX, please contact the administrator.

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Article ID: 193996

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Since I upgraded to 15.8.0.1 I get an error when running a process through an action or a HTML portlet.

Even if I have process - start rights over the given process, I am unable to run the process.

By looking to the app-ca.log file I get the following exception:

ERROR 2020-06-26 12:37:03,938 [http-nio-80-exec-933] bpm.services (clarity:myuser:5632180__2D600D19-446D-4577-B639-5A6D88BB442A:odata.StartProcess) Authorization is failed. Cannot start Process 5004001
ERROR 2020-06-26 12:37:14,594 [http-nio-80-exec-948] clarity.ui (clarity:myuser:5632180__2D600D19-446D-4577-B639-5A6D88BB442A:security.logs) UI_MSG[:Fri Jun 26 2020 14:37:09 GMT 0200 (Central European Summer Time):BPM-0013: You do not have rights to start one or more of the processes you selected.]

Environment

Clarity PPM 15.7.1.3 or higher, 15.8.0.1 and 15.8.1 or higher

Cause

In 15.7.1.3, 15.8.0.1 and 15.8.1 the following defect was fixed:

DE53552: Processes can be run through a HTML portlet even if the user does not have access rights to run processes 

As per the defect fix, whenever a process is launched the Process - Manage access right is checked
If the user does have the right, the process is initiated. Otherwise the error is thrown.

Resolution

Grant the Process - Manage access right to the affected user

Additional Information

Administration Access Rights