Report fails for a certain user with "Query is greater than 50000 bytes"
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Report fails for a certain user with "Query is greater than 50000 bytes"

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Article ID: 193737

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

Getting the following message, when try to generating reports using "broadcomtest" user ID. 

Data error accessing the enterprise manager, Query is greater than 50000 bytes

The same reports generation gets completed successfully when using Administrator ID.

Environment

Release : 10.7.0

Component : APM Agents

Cause

1. Normally this error 'Query length is greater than 50000 bytes. means, there are too many metrics included in the query."

2. EM and Workstation Client are notthe same version 

3. The query log doesn't show any entries for the user 'broadcomtest' but shows for the 'newuser'.

Resolution

1. Try removing metric group to lessen the report queries

2.  Upgrade Workstation client consoles are same version as EM ,

3. User 'broadcomtest' may have conflict  with another similar user ID or corrupted 

Try creating a new / unique user DI and assign Introscope Permission.