"Unable to process request" error pops-up
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"Unable to process request" error pops-up

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Article ID: 193635

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Following error is shown in the browser, when users navigate into various pages of the product, such as timesheets, overview, projects list etc.

[en - Unable to process request - Server or Network error]

Error samples from app-ca.log:

Caused by: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 24256; An invalid XML character (Unicode: 0x1f) was found in the value of attribute "value" and element is "tip".
uif.UIServlet (clarity:none:none:none) 
java.lang.Exception: Could not transform view xml into html
ERROR 1940-12-12 19:30:10,848 [http-nio-8081-exec-21] vxml.VXMLService (clarity:someUser:3712345454__3F315340-AF30C71D:npt.overview) Exception in processing
com.niku.union.web.WebException: Could not transform view xml into html. 
Page Xml: <page title="概要: 概要" layout="three-column-layout" personalize="true" studio="true">
...
...
Caused by: net.sf.saxon.trans.DynamicError: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 5374; Character reference "&#6" is an invalid XML character.
    at net.sf.saxon.event.Sender.sendSAXSource(Sender.java:282)
...
...
Caused by: net.sf.saxon.trans.DynamicError: Error in call to extension function {public void com.niku.union.xsl.TimePeriod.setViewAttribute(java.lang.String,java.lang.String)}: Sequence contains more than one value; Java method expects only one

uif.UIServlet (clarity:none:none:none) 
java.lang.Exception: Could not transform view xml into html. 

Environment

Release : 15.x, 16.x

Component : CA PPM APPLICATION

Cause

First error sample above was due to the following bad character in a Timesheet. The "Unit Separator" character. This was likely introduced with a copy/paste as it could not have been typed manually.

0x1f

The second sample was due to a corrupted record in the cmn_captions_nls table.

The this sample was due to a corruption in the columns that were added to the list view.

Resolution

If you review the Clarity logs using a text editor that can see the special character (Notepad++ for example), view the section in the logs just prior to the error messages noted above. This should show you the full load of the xml, and you should see the special character (usually represented by a black box with text). Once you determine where the bad character is located, it can be found in the timesheet (or any other page of the product) and fixed.

Resetting the particular list view also helps.