Clarity PPM - "Unable to process request" while opening timesheet

book

Article ID: 193635

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

A user is getting error while opening the timesheet:

[en - Unable to process request - Server or Network error]

 

Errors in logs:

Caused by: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 24256; An invalid XML character (Unicode: 0x1f) was found in the value of attribute "value" and element is "tip".

uif.UIServlet (clarity:none:none:none) 
java.lang.Exception: Could not transform view xml into html. 

Cause

Somewhere in the Timesheet for this user, there's a bad character:

0x1f

This is a "Unit Separator" character. This character was likely introduced with a copy/paste as it couldn't be manually typed.

Environment

Release : 15.5

Component : CA PPM APPLICATION

Resolution

If you review the Clarity logs using a text editor that can see the special character (Notepad++ for example), view the section in the logs just prior to the error messages noted above. This should show you the full load of the xml, and you should see the special character (usually represented by a black box with text). Once you determine where the bad character is located, it can be found in the timesheet and fixed.