Data Aggregator install does not prompt to choose IP Address
search cancel

Data Aggregator install does not prompt to choose IP Address

book

Article ID: 193455

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

The Data Aggregator servers are dual NIC hosts with more than one active valid IP available for use.

Need to specify which one is used by the Data Aggregator.

We upgraded the Data Aggregator in a lab and then in production. In the lab install it prompted for an IP address to be selected.

In the production upgrade it never prompted for an IP selection and used the wrong IP address.

Environment

All Supported Performance Management releases

Cause

Logic in the installation is incorrect resulting in this problem which will be fixed via defect DE467204.

What is our DA install code doing? How does it know whether to prompt the user for an IP choice? In the InstallAnywhere code:

  1. First it gets the HOST_PRIVATE_ADDR_* and HOST_ADDR_* values.
    • If there is only a single private address found we set that for CONSUL_BIND_ATTR.
    • If there isn't a private IP address CONSUL_BIND_ATTR isn't set yet.
  2. If CONSUL_BIND_ATTR isn't set and there is no private address and only 1 host address, we use the host address value to set CONSUL_BIND_ATTR.
  3. If after that the CONSUL_BIND_ATTR still isn't set, where there isn't a private address and there is more than 1 host address, we prompt for what address to use.

Behind the scenes, it is Java that checks the available IPs against those ranges. It then marks the IP as a siteaddress or not. Our installer then checks java for isSiteAddress to determine if the IPs found are of a private_addr type or not.

Resolution

There is no way to avoid this without configuring interfaces on the Data Aggregator hosts pre-install, and resetting the configuration again post-install.

If we see at least one of the IPs being in the private address ranges per the "ifconfig -a" output, this issue will be seen.

To resolve this we need to manually update the bind_address for the Data Aggregator and restart it.

If this is observed on your Data Aggregator the information in the following Knowledge Base article will help to resolve it.

The change to our installer recommended by engineering is checking in IA rules to see if host_addr has values and size > 1. If it's 1, then private addr == host addr.

This will be resolved via DE467204. This will be included in the pending r3.7.14 and r20.2.2 releases.

Additional Information

What is a Private Address? Private Address will always be an IP found in one of these ranges.

  • 10/8
  • 172.16/12
  • 192.168/16

Translated that becomes IPs in ranges:

  • 10.*
  • 172.16.*
  • 192.168.*